Navigation: Home ›  Produkte ›  OpenMP

Hinweise zur Nutzung von OpenMP- und MPI-Modellversionen

WaSiM-ETH unterstützt Open Multi-Processing (OpenMP) seit 2007 (ab WaSiM 7.5).

Die eingesetzte Shared-Memory-Programmierung ermöglicht WaSiM-ETH eine optimale Ausnutzung der Rechenleistung von Mehrkern-Computern, sowohl unter Windows- als auch unter Linux-Betriebssystemen.

Die Verwendung der OpenMP-Modellversionen unter Windows setzt die Installation der kostenfreien Microsoft Visual C++ Runtime DLLs auf dem Ziel-PC voraus.

Die DLLs können im Internet mit den folgenden Suchbegriffen gefunden und heruntergeladen werden:
"Microsoft Visual C++ 2010 Redistributable Package (x64)" für WaSiM bis Version 9.08.02 (32 and 64 bit)
"Microsoft Visual C++ 2013 Redistributable Package (x86)" für WaSiM ab Version 9.08.03 (32 and 64 bit)

siehe auch: lib-package 32-bit und lib-package 64-bit

Parallele Modellrechnungen auf verteilten Computersystemen via Message Passing Interface (MPI) sind mit WaSiM-ETH nun ebenfalls möglich. Entsprechende Modellversionen sind verfügbar, müssen aber in der Regel speziell auf dem Supercomputer, auf dem sie laufen sollen, übersetzt werden. Die Nutzung der MPI-unterstützenden Modellversionen setzt das Vorhandensein (Installation) eines MPI-framework voraus, z.B. MPICH2 für Windows oder mpi-1.1 packages für Linux.

back top home

WaSiM-News

04.11.2017

Neuer Patch verfügbar:
WaSiM 10.00.03 -> Mehr »